EXCEL 2007 – Compter le nombre de cellules répondant à 2 critères ou plus

Si on trouve facilement comment compter le nombre de cellules répondant à un critère, par exemple, combien de cellules sur ma colonne E ont pour valeur « Oui »…

Alors, combien ? hum ?

Bon, la fonction que l’on trouve facilement est

NB.SI(plage;critère)

lien du descriptif de la fonction chez Office plutôt bien fait.

J’ai cherché un peu pour trouver comment intégrer plusieurs critères à mon comptage. En effet, je voulais savoir combien de cellules contenaient la valeur « Oui » pour ma colonne E, mais seulement si les cellules correspondante dans la colonne A valaient 6.

La solution:

RESULTAT = NB.SI.ENS(E1:E10000; »Oui »;A1:A10000;6) 

On reprend donc la philosophie de la fonction NB.Si mais en effectuant une succession de couple plage;critère.

Ici, la première plage est l’ensemble des 10000 premières cellules de la colonne E sur laquelle on teste la valeur « Oui », la seconde plage est l’ensemble des 10000 premières cellules de la colonne A sur laquelle on teste la valeur 6. Le résultat ne comptera que les cellules répondant aux deux critères simultanéments.

On peut ajouter autant de couple plage/critère que souhaité.

Si ça peut aider, le mal qu’on se donne est bien peu de peine.

  1. ca marche pas copnnard

    • Voilà une remarque super constructive.
      Et surtout, une insulte bien gratuite.
      On peut s’interroger: Qu’est-ce qui ne marche pas ?
      Qu’avez vous cherché à faire et comment l’avez vous fait ?
      Je suis prêt à regarder de plus prêt le contenu de la formule que vous avez utilisé.
      Peut-être également un problème de version, je reconnais ne pas avoir précisé que mes essais ont été fait sur excel 2007.
      Une opportunité pour vous en même temps de faire vos excuses, après tout, vous aviez besoin d’aide, et si l’aide n’a pas été apporté, nous avons au moins le mérite d’avoir essayé non ? Merci mais avec moi ca ne marche pas aurait été un post plus adapté.
      Christophe.

  2. Eh bien pour moi, ça marche (sur excel 2010) !
    Merci beaucoup

  3. Quelle formule faire, dans Excel, pour compter le nombre de fois, que Serge a fait de menuiserie dans le mois ? sachant qu’il a aussi fait de la peinture ? Merci de me dépanner ?

  4. Effectivement, la fonction NB.SI.ENS n’existe que depuis la version 2007 d’EXCEL, je corrige le titre du POST.

Laisser un commentaire


NOTE - Vous pouvez utiliser les éléments et attributs HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>